В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

Составить программу на паскале. на турнире соревновались два спортсмена – а и в. всего было проведено n туров. результаты каждого спортсмена по турам записаны в два массива а и в. победителем в каждом туре считается тот, кто в этом туре набрал больше очков. победителем соревнования считается тот, кто победил в большем количестве туров. определить, кто победил в соревновании. если а и в победили одинаковое число раз, то засчитывается ничья.

Показать ответ
Ответ:
Angela11001
Angela11001
27.08.2020 15:56

var

 a: array of real;

 b: array of real;

 a_sum, b_sum, i, n: integer;

 a_values, b_values: real;

begin

 randomize;

 writeln('Введите количество туров: ');

 readln(n);

 a := new real[n];

 b := new real[n];

 a_sum := 0;

 b_sum := 0;

 writeln('Введите результаты первого спортсмена: ');

 for i := 0 to n - 1 do  

 begin

   readln(a_values);

   a[i] := a_values;

 end;

 writeln('Введите результаты второго спортсмена: ');

 for i := 0 to n - 1 do  

 begin

   readln(b_values);

   b[i] := b_values;

 end;

 writeln('Результаты первого спортсмена: ');

 for i := 0 to n - 1 do  

   write(a[i], ' ');

 writeln(#10);

 writeln('Результаты второго спортсмена: ');

 for i := 0 to n - 1 do  

   write(b[i], ' ');

 writeln(#10);

 for i := 0 to n - 1 do

   if (a[i] > b[i]) then inc(a_sum) else  

   if a[i] = b[i] then begin inc(a_sum);inc(b_sum); end else  

   if (a[i] < b[i]) then inc(b_sum);

 writeln('Первый спортсмен победил в ', a_sum, ' турах.', #10, 'Второй спортсмен победил в ', b_sum, ' турах.');

 if (a_sum = b_sum) then writeln('В общем зачёте ничья!') else  

 if (a_sum > b_sum) then writeln('В общем зачёте побеждает первый спортсмен!') else  

 if (a_sum < b_sum) then writeln('В общем зачёте побеждает второй спортсмен!');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота