В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
valeriya210322
valeriya210322
09.08.2020 12:35 •  Информатика

Составить программу на Паскале для обработки одномерного массива из 10 элементов. Значения элементов задать вводом с клавиатуры самостоятельно. Посчитать количество и напечатать номера элементов, которые больше 5. Программная реализация обязательна. На проверку нужно прислать коды программ и результаты работы в окне программы Паскаль.

Показать ответ
Ответ:
ksdkjxddjcksmsfmkf
ksdkjxddjcksmsfmkf
30.07.2022 20:24
// PascalABC.NET 3.2, сборка 1447 от 22.05.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('Количество строк в массиве:');
  var m:=ReadInteger('Количество колонок в массиве:');
  Writeln('*** Исходный массив [',n,',',m,'] ***');
  var a:=MatrRandom(n,m,-99,99);
  a.Println(5); Writeln(5*a.ColCount*'-');
  a.Cols.Select(x->Format('{0,5}',x.Where(y->y<0).Sum)).Print('');
  Println(' - суммы отрицательных');
end.

Пример
Количество строк в массиве: 5
Количество колонок в массиве: 9
*** Исходный массив [5,9] ***
  -43  -96   34   82    3   92  -59   31   35
   65   94   76   66   90  -39   26  -24   83
   73  -92   94  -94   44  -35  -66   87  -46
   90   56  -37  -60   -9   94    9  -76  -58
  -16   97   65  -21  -86   64  -20   46  -26

  -59 -188  -37 -175  -95  -74 -145 -100 -130 - суммы отрицательных
0,0(0 оценок)
Ответ:
dimabeliu2016
dimabeliu2016
28.02.2023 12:22
Using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.Threading.Tasks;

namespace СиШарп
{
    class Program
    {
        static void Main(string[] args)
        {
            Console.Write("N = ");
            int N = int.Parse(Console.ReadLine());
            Console.Write("A({0}):",N);
            double[] A = new double[N];
            int Max = 1, Min = 1;
            Random RND = new Random();
            for (int i = 0; i < N; i++)
            {
                A[i] = RND.NextDouble() * N;
                Console.Write(" {0:0.0}",A[i]);
                if (A[i] > A[Max]) Max = i;
                if (A[i] < A[Min]) Min = i;
            }
            Console.WriteLine("\nMin(A) = {0:0.0}[{1}]",A[Min],Min+1);
            Console.WriteLine("Max(A) = {0:0.0}[{1}]", A[Max], Max+1);
            Console.ReadKey();
        }
    }
}

N = 13
A(13): 11,0 9,2 4,5 12,0 2,5 11,1 9,6 10,4 0,2 10,2 6,7 0,4 10,0
Min(A) = 0,2[9]
Max(A) = 12,0[4]
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота