В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
likaaaasf
likaaaasf
21.10.2022 03:37 •  Информатика

Составить программу на паскале. даны стороны двух треугольников. найти сумму их периметров и сумму площадей. определить процедуру для расчета периметра и площади треугольника по его сторонам

Показать ответ
Ответ:
danilcapitan
danilcapitan
03.10.2020 18:41
//Pascal ABC.NET 3.1 сборка 1219

procedure PerAndPlo(var s,p:real;a,b,c:real);
Var
 pp:real;
begin
  p:=a+b+c;
  pp:=p/2;
  s:=sqrt(pp*(pp-a)*(pp-b)*(pp-c));
end;

Var
 a1,b1,c1,p1,s1,a2,b2,c2,p2,s2:real;
begin
Writeln('Введите длины сторон первого треугольника:');
readln(a1,b1,c1);
Writeln('Введите длины сторон второго треугольника:');
readln(a2,b2,c2);
PerAndPlo(s1,p1,a1,b1,c1);
PerAndPlo(s2,p2,a2,b2,c2);
Writeln('Сумма периметров:',(p1+p2));
Writeln('Сумма площадей:',(s1+s2));
end.

Пример ввода:
1
2
3
4
5
6
Пример вывода:
Сумма периметров:21
Сумма площадей:9.92156741649221
0,0(0 оценок)
Ответ:
bachko2012
bachko2012
03.10.2020 18:41
Var z,x,c:real;
procedure Perimetr(a,b,c:real);
var p:real;
begin 
p:=a+b+c;
writeln('P=',p);
end;

procedure Ploshad(a,b,c:real);
var s,p:real;
begin
p:=(a+b+c)/2;
s:=sqrt(p*(p-a)*(p-b)*(p-c));
writeln('S=',s);
end;

begin
writeln('Write first data:');
readln(z,x,c);
Perimetr(z,x,c);
Ploshad(z,x,c);

writeln('Write second data:');
readln(z,x,c);
Perimetr(z,x,c);
Ploshad(z,x,c);
readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота