В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Пушка1244
Пушка1244
07.04.2020 17:31 •  Информатика

Составить программу на C++, которая выводит на экран количество и все номера позиций, на которых встречается буква к.

Показать ответ
Ответ:
1user
1user
04.05.2021 15:55

Процесс создания мультипликационного фильма состоит из многих этапов. Сначала придумывается сюжет мультика, пишется его сценарий, где описывают поэтапно все события, которые в нем будут происходить, создаются эскизы героев. Но не всем известно, что для того чтобы такой нарисованный персонаж ожил и находился в движении в течение одной минуты, понадобится более чем полторы тысячи рисунков. Такие изображения называются кадрами. Они столь быстро меняются один за другим, что человеческие глаза воспринимают это чередование, как живую картинку. Чтобы форма объектов изменялась плавно, за одну секунду должно поменяться 12 – 16 кадров. Такой принцип имитации движения ещё называют анимацией.

Объяснение:

Думаю так

0,0(0 оценок)
Ответ:
magnolyabz
magnolyabz
26.03.2020 07:33

Типовая задача на разбор случаев. Разбирать случаи будем не простым последовательным перечислением, а более сложной конструкцией из вложенных условных операторов.

Решение задачи.

Var a1, b1, c1, {коэффициенты уравнения первой прямой}

    a2,b2,c2, {коэффициенты уравнения второй прямой}

    x, y : Real; {координаты точки пересечения }

BEGIN

ReadLn( a1, b1, c1);

ReadLn( a2, b2, c2);

 If ( (a1=0) and (b1=0) ) or ( (a2=0) and (b2=0) )

 then WriteLn( 'это не прямая (прямые). ' )

 else

  if (a1*b2=a2*b1) and (a1*c2=a2*c1) {условие совпадения}

   then WriteLn( 'прямые совпадают.' )

   else

    if a1*b2 = a2*b1 {условие параллельности}

     then WriteLn('прямые параллельны.')

     else begin x:=(c1*b2-c2*b1)/(b1*a2-b2*a1);

         y:=(c2*a1-c1*a2)/(b1*a2-b2*a1);

         WriteLn('координаты точки пересечения :',

        ' x = ', x : 5 : 2 , ', y = ', y : 5 : 2);

          end;

END.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота