В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Sashalizanika
Sashalizanika
22.06.2022 07:17 •  Информатика

Составить программу на а паскаль для вычисление закона джоуля ленца q=i2(степень)*r*t если q=1296дж i=9a t=2c

Показать ответ
Ответ:
карина2153
карина2153
29.10.2022 05:25
// PascalABC.NET 3.0, сборка 1076
begin
  var n:=ReadInteger('Число элементов массива=');
  var a:=ArrRandom(n,-25,25);
  Write('Исходный массив: '); a.Println;
  var k:=a.Where(x->sqr(x)>sqr(a[0])).Count;
  if k>0 then Writeln
    ('Найдено ',k,' элементов, квадрат которых больше квадрата первого')
  else Writeln
    ('Нет ни одного элемента, квадрат которого больше квадрата первого')
end.

Тестовое решение:
Число элементов массива=15
Исходный массив: 11 12 -11 -3 -16 -22 22 4 -4 -1 -16 -9 -19 4 16
Найдено 7 элементов, квадрат которых больше квадрата первого
0,0(0 оценок)
Ответ:
maanna24
maanna24
10.12.2022 10:57

Основные - это те без которых он не будет работать?:

монитор - отображение видеоинформации

видеокарта - обработка и подача видеосигнала на монитор

клавиатура и мышь - ввод информации от пользователя

блок питания - распределение питания между внутренними устройствами

жёсткий диск - постоянная память компьютера

оперативная память - временная память компьютера

процессор - основные вычислительные операции

материнская плата - связыает все элементы между собой

куллер - охлаждает

системный блок - для крепления внутренних элементов

дополнительные устройства ввода: сд или двд приводы, сканер, тачпад на ноутах, сенсорные понели, вэбкамеры, микрофоны...

дополнительные устройства вывода: колонки или наушники + звуковая карта, принтеры, плоттеры, проэкторы..

устройства для коммуникаций и сетей: модемы, сетевые карты, блютус/ик платы или стационарные устройства..

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота