В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
balatzkymaxp0a4t7
balatzkymaxp0a4t7
09.02.2023 09:17 •  Информатика

Составить программу, которая запрашивает координаты двух точек, а выводит длину отрезка, концами которого эти точки являются, и координаты середины этого отрезка. (блок систему и на языке паскаль)

Показать ответ
Ответ:
Притти
Притти
04.10.2020 20:39
Program Programma;
Uses crt;

var xA,xB,yA,yB,D: real;

Begin clrscr;
write('Введите координаты точки A через пробел: ');
readln(xA,yA);
write('Введите координаты точки B через пробел: ');
readln(xB,yB);

d:=sqrt(sqr(xA-xB)+sqr(yA-yB));
writeln;
write('Длина отрезака AB = ',d:0:3)
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота