В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

Составить программу, которая заполнит массив по правилу:
(числа от 1 до 30)


Составить программу, которая заполнит массив по правилу:(числа от 1 до 30)

Показать ответ
Ответ:
oxanalusevich
oxanalusevich
07.01.2021 06:35

#include <iostream>

#include "string.h"

#include "stdlib.h"

using namespace std;

int main()

{

setlocale(LC_ALL, "rus");

int x; int mas1[30];

for (int i = 0; i < 15; i++) {

 x = rand() % 10;

 mas1[i] = x * x + 4;

}

for (int i = 15; i < 30; i++) {

 x = rand() % 10;

 mas1[i] = 3 * x - 10;

}

for (int i = 0; i < 30; i++) {

 cout << mas1[i] << "\n";

}

}

Объяснение:

числа псевдорандомные от 0 до 10

0,0(0 оценок)
Ответ:
skutovakseniya2004
skutovakseniya2004
07.01.2021 06:35

program massiv;

var i: integer;

mas: array[1..30] of integer;

begin

 for i:= 1 to 30 do

 begin

   if i < 16 then

     mas[i]:= sqr(i) + 4

   else

     mas[i]:= 15*(3*i-10);

 end;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота