В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
IgorPoberezhny
IgorPoberezhny
26.01.2022 06:49 •  Информатика

Составить программу которая вычисляет произведение членов последовательности n натуральных чисел, кратных 5. программа получает на вход целые числа, количество введеных чисел неизвестно, последовательность заканчивается числом n.

Показать ответ
Ответ:
Maximus20161
Maximus20161
03.10.2020 10:14
В условии задачи есть противоречие: с одной стороны количество чисел = N, а с другой - количество неизвестно, а дается признак конца последовательности. Программа дана для 2-го варианта.
var n,a:integer; p:real;
begin
write('n = '); readln(n);
write('a = '); readln(a);
p:=1;
while a<>n do
 begin
 if a mod 5 = 0 then p:=p*a;
 write('a = '); readln(a);
 end;
writeln('p = ',p);
end.

Пример:
n = 999
a = 6
a = 10
a = 24
a = 15
a = 56
a = 7
a = 5
a = 999
p = 750
0,0(0 оценок)
Ответ:
markvT
markvT
03.10.2020 10:14
Мой милорд, прибыли поставки в виде решения
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота