В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
begem0tcs
begem0tcs
31.07.2020 12:28 •  Информатика

Составить программу,которая в зависимости от порядкового номера месяца выводит на экран количество дней в этом месяце.рассмотреть два случая: 1.год високосный. 2.год не является високосным

Показать ответ
Ответ:
KateySh
KateySh
12.07.2020 19:24
Program G;
Uses Crt;
Var count, num, ch: integer;
Begin 
 ClrScr; 
 Writeln('Год високосный? 1 - да, 0 - нет'); 
 Readln(Ch); 
 If ch=1 then 
  Begin   
   Writeln('Введите номер месяца'); 
   Readln(num);   
   Сase num of  
    1, 3, 5, 7, 8, 10, 12: writeln('В месяце 31 день.'); 
    4, 6, 9, 11: writeln('В месяце 30 дней.'); 
    2: writeln('В месяце 29 дней');   
   else writeln('Некорректный ввод данных')   
  End; 
 End  
 Else if ch=0  then 
  Begin   
   Writeln('Введите номер месяца');    
   Readln(num);
   Сase num of    
    1, 3, 5, 7, 8, 10, 12: writeln('В месяце 31 день.');   
    4, 6, 9, 11: writeln('В месяце 30 дней.');   
    2: writeln('В месяце 28 дней');   
   else writeln('Некорректный ввод данных')   
   End; 
  End 
 Else writeln('Некорректный ввод данных');
Readln; 
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота