В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
вап27
вап27
24.10.2022 22:49 •  Информатика

Составить программу, которая в последовательности целых чисел находит сумму чисел кратных 7 в диапозоне от 6 до 80. программа получает на вход целые числа, кол-во не известно, 0-признак окончания входные данные: -7,14,84,0 составить по паскалю

Показать ответ
Ответ:
Sunrise01
Sunrise01
13.06.2020 03:29

programm p;

var

 a:array[1..100 ] of integer;

i,n:integer;

s:integer;

begin

readln n;

for i:=1 to n do

readln(a[i]);

 

s:=0;

for i:=1 to n do

begin

if (a[i]>5)and(a[i]<81)and(a[i]/7=int a[i]/7) then

s:=s+a[i];

if a[i]= 0 then break;

end;

writeln(s);

end.

 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота