В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
ikilan201
ikilan201
09.04.2020 04:38 •  Информатика

Составить программу, которая в одномерном массиве размерностью 15, состоящим из случайных чисел из промежутка от 20 до 80,находится наибольший элемент оканчивающийся на цифру 2 или 8

Показать ответ
Ответ:
vorobeva85ramon
vorobeva85ramon
27.08.2020 13:52

var a: array[1..15] of integer;

i,m: integer;

begin

writeln('массив:');

for i:=1 to 15 do

begin

a[i]:=random(61)+20;

write(a[i],' ');

end;

m:=-1;

writeln;

for i:=1 to 15 do

if ((a[i] mod 10=2) or (a[i] mod 10=8)) and (a[i]>m) then m:=a[i];

if m=-1 then write('такого элемента нет') else writeln('m=',m);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота