В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
irinalika
irinalika
28.06.2021 11:33 •  Информатика

Составить программу, которая строит график зависимости y(x)=x^2+9sin x на отрезке[-13;23]

Показать ответ
Ответ:
baubaubau
baubaubau
29.09.2021 08:18
1 задача:

const n=10;
var 
  min,i: integer;
  a: array[1..n] of integer;
begin
  randomize;
  min:=11;
  for i:=1 to n do begin
    a[i]:=random(1,10);
    write (a[i],' '); // для наглядности. можно удалить
    if  (i mod 2 =1) and (a[i]<min) 
      then min:=a[i];    
  end;
  writeln;
  writeln ('min = ',min)
end.

Пример:
5 4 7 8 6 2 10 4 9 9 
min = 5


2 задача:

const n=10;
var 
  max,count,i: integer;
  a: array[1..n] of integer;
begin
  randomize;
  max:=0;
  count:=0;
  for i:=1 to n do begin
    a[i]:=random(1,10);
    write (a[i],' '); // для наглядности. можно удалить
    if a[i]>max
      then max:=a[i];     
  end;
  for i:=1 to n do 
    if max=a[i] then count:=count+1;
  writeln;
  writeln ('max = ',max);
  writeln ('count = ',count);
end.

Пример:
8 5 3 2 2 10 10 9 3 10 
max = 10
count = 3
0,0(0 оценок)
Ответ:
liyanborisova
liyanborisova
22.03.2020 10:27
// PascalABC.NET 3.2, сборка 1353 от 27.11.2016
// Внимание! Если программа не работает, обновите версию!

begin
  // заполним информацию случайным образом;
  // если хорошистов в результате не окажется,
  // просто перезапускаем задачу
  randomize;
  var a:=MatrRandom(13,10,4,5); // везде только 4 и 5
  for var i:=1 to 20 do // раскидаем 20 троек
    a[Random(13),Random(10)]:=3;
  a.Println(2); Writeln;
  // собственно, решение
  var k:=0;
  foreach var r in a.Rows do
    if r.All(x->x<>3) and not r.All(x->x=5)  then k+=1;
  Writeln(k,' хорошистов')
end.

Пример
5 5 4 4 4 5 3 3 4 4
 5 4 4 4 3 4 5 5 4 5
 5 5 5 3 5 4 4 5 5 4
 3 5 4 3 4 4 5 5 5 3
 5 3 4 4 5 4 4 5 5 4
 3 5 5 5 5 4 4 4 4 3
 4 4 5 3 5 4 4 5 4 5
 4 5 4 4 4 4 4 4 5 4
 3 5 3 4 4 4 4 4 5 3
 5 5 4 5 4 4 4 5 4 5
 4 5 4 5 4 5 3 4 5 5
 4 5 4 4 4 4 5 4 4 5
 4 3 5 4 4 4 5 5 3 5

3 хорошистов
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота