В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Lizka647dhsn
Lizka647dhsn
12.01.2020 01:16 •  Информатика

Составить программу ,которая последовательно циклически запрашивает 40 целых положительных чисел и назодит минимальное значение среди чётных чисел. минимальное значение вывести на экран

Показать ответ
Ответ:
julija74
julija74
08.06.2020 03:42

program nnn;

uses crt;

var

i,m:integer;

a:array[1..40] of integer;

begin

for i:=1 to 40 do

begin

read(a[i]);

end;

m:=a[1];

for i:=1 to 40 do

begin

if a[i] mod 2 = 0 then if m>a[i] then m:=a[i];

end;

writeln(m);

end.

если без массива:

program nnn;

uses crt;

var

i,c,m:integer;

begin

for i:=1 to 40 do

begin

read(c);

if i=1 then m:=c;

if c mod 2 = 0 then if m>c then m:=c;

end;

writeln(m);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота