В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
StasDvorchuk
StasDvorchuk
21.01.2020 11:18 •  Информатика

Составить программу, которая поменяла значения двух переменных a и b . нужна !

Показать ответ
Ответ:
алиса769
алиса769
25.05.2020 22:42

var

  a, b, c: real; {c - буферная переменная, в которой будет хранится значение переменной а}

 

begin 

  writeln('Введите 2 числа');

  readln(a, b);  //Вводим значения переменных а и b

  writeln(a, '  ', b);  //Печатаем значения переменных а и b

  c:= a;  //Присваиваем переменной с значение переменной а

  a:= b; //Присваиваем переменной а значение переменной b 

  b:= c;  //Присваиваем переменной b значение переменной c

  writeln(a, '  ', b);  //Печатаем измененные значения

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота