В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

Составить программу, которая подсчитывает для каждого столбца массива а[1..5, 1..6] сумму значений элементов и формирует из полученных сумм одномерный массив b[1..6].

Показать ответ
Ответ:
Evgenia601
Evgenia601
06.06.2020 21:07

Программа на Паскале:

Program a1;

Var i, j : integer;

      s : real;

      a: array [1..5, 1..6] of real;

      b: array [1..6] of real;

Begin

  For i:=1 to 5 do

    For j:=1 to 6 do

       readln(a[i,j]);

  For j:=1 to 6 do

    Begin

       s:=0;

       For :=1 to 5 do

           s:=s+a[i,j];

       b[j]:=s

    end;

 Write ('Полученный массив В:');

 For j:=1 to d do

    write(b[j]);

 readln

End. 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота