В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
TemirMamekov
TemirMamekov
29.06.2020 12:54 •  Информатика

Составить программу, которая печатает столбик таблицы умножения натурального числа в десятичной системе счисления, вводимого с клавиатуры. Например, с клавиатуры вводится число 5, должно быть напечатано:

5*1=5

5*2=10



5*10=50.
паскаль абс

Показать ответ
Ответ:
nik868
nik868
22.12.2021 21:45
Function prime(x:integer):boolean;
var
 t:boolean;
 d:integer;
begin
 t := true;
 d := 2;
 while t and (d*d <= x) do
   begin
   if x mod d = 0 then 
     t := false;
   d := d + 1
   end;
 prime := t
end;

function order(x:integer):boolean;
var
 t:boolean;
 d:integer;
begin
 d := -1;
 repeat
   t := x mod 10 > d;
   d := x mod 10;
   x := x div 10
 until not t or (x = 0);
 order := t
end;

var
 t:boolean;
 i,k,n:integer;
begin
 t := false;
 read(k,n);
 for i := k to n do
   if prime(i) then
   if order(i) then
     begin
     write(i,' ');
     t := true
     end;
 if not t then
   write(0)
end.
0,0(0 оценок)
Ответ:
Ксюха12111
Ксюха12111
24.11.2020 10:29
Задание №1 

var s,v,t,a:real; 
begin 
writeln('Введите скорость, ускорение и время соотвественно'); 
read(v,a,t); 
s:=v*t+(a*sqr(t))/2; 
writeln('Расстояние S = ',s); 
end.

Задание №2

var a,b,c,d,m,n:integer; 
begin 
writeln('Введите ширину и высоту комнаты'); 
read(a,b); 
writeln('Введите размеры окна'); 
read(c,d); 
writeln('Введите размеры двери'); 
read(m,n); 
writeln('Площадь стен для оклеивания обоями = ',a*b-c*d-m*n); 
end.

Задание №3

var a,b:real; 
begin 
writeln('Введите два числа'); 
read(a,b); 
writeln('Среднее арифметическое кубов этих чисел = ',(power(a,3)+power(b,3))/2); 
writeln('Среднее геометрическое модулей этих чисел = ',sqrt(abs(a*b))); 
end.

Задание №4

var x:real; 
begin 
writeln('Введите ребро куба'); 
read(x); 
writeln('Площадь грани = ',sqr(x)); 
writeln('Площадь полной поверхности = ',6*sqr(x)); 
writeln('Объем куба = ',power(x,3)); 
end.

Задание №5

var r1,r2:real; 
begin 
writeln('Введите внешний и внутренний радиус'); 
read(r1,r2); 
if r1<r2 then writeln('Внешний радиус должен быть больше внутреннего') else 
writeln('Площадь кольца = ', Pi*sqr(r1)-Pi*sqr(r2)); 
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота