Составить программу, которая обрабатывает матрицу, согласно полученному варианту задания. Вывести на печать результаты и исходную матрицу в общепринятом виде. Ввод данных сопровождать соответствующими запросами, а вывод - наименованиями выводимых переменных Вычислить сумму положительных элементов квадратной матрицы, находящихся под главной диагональю и на ней. СДЕЛАТЬ В ПИТОНЕ!
1)
2) 3 единицы
3) 24D
4) 6
5) 2 раза
Объяснение:
2)
3) Переводим число в 16-ичную систему счисления, для этого делим его на 16 и запоминаем остаток. Затем результат деления также делим на 16 и запоминаем остаток. Повторяем эти действия до тех пор, пока частное не будет равно 0:
589 : 16 = 36, остаток 13
36 : 16 = 2, остаток 4
2 : 16 = 0, остаток 2
Затем записываем остатки от деления в обратном порядке: 2 4 13
Заменяем числа больше 9 на буквы
(10 - A; 11 - B; 12 - C; 13 - D; 14 - E; 15 - F)
Результат:
4)
5) Посчитаем от 1 до 10 в 6-ичной системе счисления:
1 2 3 4 5 10 11 12 13 14
// Внимание! Если программа не работает, обновите версию!
begin
var (n,m):=ReadInteger2('Количество строк и столбцов в матрице:');
Writeln('*** Исходная матрица ***');
var a:=MatrRandom(n,m,-99,99);
a.Println(4); Writeln(4*a.ColCount*'-');
var (q,k):=ReadInteger2('Укажите номера строк q и k:');
Assert((k<>q) and k.Between(1,n) and q.Between(1,n),'Неверная пара (q,k)');
k-=1; q-=1; // перешли к индексам
var rk:=a.Row(k);
if k<q then begin
for var r:=k+1 to q do a.SetRow(r-1,a.Row(r));
a.SetRow(q,rk)
end
else begin
for var r:=k-1 downto q+1 do a.SetRow(r+1,a.Row(r));
a.SetRow(q+1,rk)
end;
Writeln('*** Результат ***'); a.Println(4)
end.
Примеры
Количество строк и столбцов в матрице: 5 8
*** Исходная матрица ***
32 -6 -66 81 84 0 50 -83
93 5 90 -33 88 30 -5 85
-46 35 -22 74 -66 8 -3 -86
-23 -81 -82 30 -1 -71 28 19
0 -95 -30 -46 -24 -77 38 49
--------------------------------
Укажите номера строк q и k: 4 1
*** Результат ***
93 5 90 -33 88 30 -5 85
-46 35 -22 74 -66 8 -3 -86
-23 -81 -82 30 -1 -71 28 19
32 -6 -66 81 84 0 50 -83
0 -95 -30 -46 -24 -77 38 49
Количество строк и столбцов в матрице: 4 3
*** Исходная матрица ***
-68 53 -35
-83 78 -78
99 -4 -9
-86 11 -30
------------
Укажите номера строк q и k: 2 4
*** Результат ***
-68 53 -35
-83 78 -78
-86 11 -30
99 -4 -9