В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
adrian55RUS
adrian55RUS
17.06.2021 17:29 •  Информатика

Составить программу которая находит наименьшее трехзначное число имеющее 3 делителей язык паскаль

Показать ответ
Ответ:
Dhonsina
Dhonsina
26.02.2022 05:42
//"Школьный" вариант
//Pascal ABC.NET 3.1 сборка 1256

Const
 n=10;

 Var
 ar:array[1..n] of integer;
 i,max,min:integer;
b:boolean;
begin
randomize;
b:=false;
max:=integer.MinValue;
min:=integer.MaxValue;
writeln('Array:');
for i:=1 to n do
 begin
  ar[i]:=random(-100,100);
  if (ar[i]>max) and not(odd(ar[i])) and (ar[i]>0) then
  begin
   max:=ar[i];
   b:=true;
  end;
  if (ar[i]<min) and not(odd(ar[i])) and (ar[i]>0) then
  begin
   min:=ar[i];
   b:=true;
  end;
  write(ar[i]:4);
 end;
writeln;
if b=false then writeln('Нет удовлетворяющих условиям чисел') else
 begin
  writeln('Max=',max);
  writeln('Min=',min);
 end;
end.

Пример работы программы:
Array:
  98  60 -41 -88  63 -81 -77 -96 -18  51
Max=98
Min=60
0,0(0 оценок)
Ответ:
Yaryycher
Yaryycher
28.04.2022 01:08
// PascalABC.NET 3.1, сборка 1256 от 21.06.2016
begin
  case ReadInteger('Номер месяца (1-12):') of
  1,2,12:Writeln('Зима');
  3..5:Writeln('Весна');
  6..8:Writeln('Лето');
  9..11:Writeln('Осень');
  else Writeln('Неверный номер месяца')
  end
end.

Вариант "для школьников"
// PascalABC.NET 3.1, сборка 1256 от 21.06.2016
var n:integer;
begin
  Write('Номер месяца (1-12): '); Read(n);
  case n of
  1,2,12:Writeln('Зима');
  3..5:Writeln('Весна');
  6..8:Writeln('Лето');
  9..11:Writeln('Осень');
  else Writeln('Неверный номер месяца')
  end
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота