В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
кек945
кек945
18.05.2021 19:21 •  Информатика

Составить программу которая формирует массив из16 элементов случайных чисел от -20 до 20 и находит элементы с нулевыми значениями

Показать ответ
Ответ:
Liza16052006
Liza16052006
23.05.2020 18:39

Program g;
Var
A, B : Integer;
N : Integer;
S : Integer;
z:array[0..16] of integer;
i : Integer;
v:integer;
Begin
A:=(-20);
B:=20 ;
N:=16 ;
For i := 1 To N Do
Begin
S := Trunc(Random(B-A)+A);
WriteLn (i:2,'-е случайное число:',S:4);
End;
begin
writeln('Індексы элементов кратных 3:');
for v:=0 to 16 do begin
z[v]:=random(40)-20;
if z[v] mod 3 = 0 then write(v, ' ')
end;
end;
End.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота