Составить программу,которая читает два числа real а и b,затем вычисляет среднее арифметическое значение и сумму квадратов этих двух чисел.программа должна содержать две процедуры,одна для вычислений,другая для вывода на экран каждого значения.
По своему назначению компьютер - это универсальный прибор для работы с информацией. По принципам своего устройства компьютер - это модель человека, работающего с информацией.Персональный компьютер (ПК) — это компьютер, предназначенный для обслуживания одного рабочего места. По своим характеристикам он может отличаться от больших ЭВМ, но функционально выполнять аналогичные операции. По эксплуатации различают настольные (desktop), портативные (laptop и notebook) и карманные (palmtop) модели ПК.Аппаратное обеспечение. Поскольку компьютер предоставляет все три класса информационных методов для работы с данными (аппаратные, программные и естественные), принято говорить о компьютерной системе как о состоящей из аппаратных и программных средств, работающих совместно. Узлы, составляющие аппаратные средства компьютера, называют аппаратным обеспечением. Они выполняют всю физическую работу с данными: регистрацию, хранение, транспортировку и преобразование как по форме, так и по содержанию, а также представляют их в виде, удобном для взаимодействия с естественными информационными методами человека.Программное обеспечение. Программы могут находиться в двух состояниях: активном и пассивном. В пассивном состоянии программа не работает и выглядит как данные, содержательная часть которых - сведения. В этом состоянии содержимое программы можно «читать» с других программ, как читают книги, и изменять. Из него можно узнать назначение программы и принцип ее работы. В пассивном состоянии программы создаются, редактируются, хранятся и транспортируются. Процесс создания и редактирования программ называется программированием.
ответ:1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
var
Chislo, Count, Summa, n: integer;
begin
Summa := 0;
Count := 0;
readln(Chislo);
while Chislo > 0 do
begin
n := Chislo mod 10;
if odd(n) then
begin
Summa := Summa + n;
inc(Count);
end;
Chislo := Chislo div 10;
end;
writeln('Сумма нечетных цифр числа: ', Summa);
writeln('Кол-во нечетных цифр числа: ', Count);
writeln('Среднее арифметическое нечетных цифр: ', Summa / Count);
end.
Объяснение:
По своему назначению компьютер - это универсальный прибор для работы с информацией. По принципам своего устройства компьютер - это модель человека, работающего с информацией.Персональный компьютер (ПК) — это компьютер, предназначенный для обслуживания одного рабочего места. По своим характеристикам он может отличаться от больших ЭВМ, но функционально выполнять аналогичные операции. По эксплуатации различают настольные (desktop), портативные (laptop и notebook) и карманные (palmtop) модели ПК.Аппаратное обеспечение. Поскольку компьютер предоставляет все три класса информационных методов для работы с данными (аппаратные, программные и естественные), принято говорить о компьютерной системе как о состоящей из аппаратных и программных средств, работающих совместно. Узлы, составляющие аппаратные средства компьютера, называют аппаратным обеспечением. Они выполняют всю физическую работу с данными: регистрацию, хранение, транспортировку и преобразование как по форме, так и по содержанию, а также представляют их в виде, удобном для взаимодействия с естественными информационными методами человека.Программное обеспечение. Программы могут находиться в двух состояниях: активном и пассивном. В пассивном состоянии программа не работает и выглядит как данные, содержательная часть которых - сведения. В этом состоянии содержимое программы можно «читать» с других программ, как читают книги, и изменять. Из него можно узнать назначение программы и принцип ее работы. В пассивном состоянии программы создаются, редактируются, хранятся и транспортируются. Процесс создания и редактирования программ называется программированием.