Составить программу, которая бы запрашивала хнач и хкон и определяла произведение всех положительных чисел от хнач до хкон (решить , используя цикл с предусловием – while .. do). пож
Var xk,xn:real; i,r,xik,xin:integer; b:boolean; begin b:=false; r:=1; read(xn,xk); xin:=round(xn-frac(xn)); xik:=round(xk-frac(xk)); i:=xin; while i<=xik do begin if i>0 then begin r:=r*i; b:=true; end; inc(i); end; if b=true then write(r) else write('0'); end.
Var
xk,xn:real;
i,r,xik,xin:integer;
b:boolean;
begin
b:=false;
r:=1;
read(xn,xk);
xin:=round(xn-frac(xn));
xik:=round(xk-frac(xk));
i:=xin;
while i<=xik do
begin
if i>0 then
begin
r:=r*i;
b:=true;
end;
inc(i);
end;
if b=true then write(r) else write('0');
end.
Пример ввода:
-2.8
3.8
Пример вывода:
6