В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
alese4kas94p0cen0
alese4kas94p0cen0
20.06.2020 04:03 •  Информатика

Составить программу, которая будет переводить COP в оценку
в Python

Показать ответ
Ответ:
sasoort1
sasoort1
20.01.2023 14:45

Как создать свой Layout с элементами (LinearLayout,Spinner,View и т.п.) внутри так, чтобы управлять их расположением и анимацией?

main_activity.xml:

   <LinearLayout

       android:id = "@+id/window_1"

       android:layout_width="200dp"

       android:layout_height="100dp"

       android:orientation="vertical">

       <Spinner

           android:id="@+id/WindowSpinner_1"

           android:layout_width="match_parent"

           android:layout_height="?attr/actionBarSize"/>

       <FrameLayout

           android:id="@+id/container_1"

           android:layout_width="match_parent"

           android:layout_height="match_parent">

       </FrameLayout>

   </LinearLayout>

   <LinearLayout

       android:id = "@+id/window_2"

       android:layout_width="200dp"

       android:layout_height="100dp"

       android:orientation="vertical">

       <Spinner

           android:id="@+id/WindowSpinner_2"

           android:layout_width="match_parent"

           android:layout_height="?attr/actionBarSize"/>

       <FrameLayout

           android:id="@+id/container_2"

           android:layout_width="match_parent"

           android:layout_height="match_parent">

       </FrameLayout>

   </LinearLayout>

   <LinearLayout

       android:id = "@+id/window_3"

       android:layout_width="200dp"

       android:layout_height="100dp"

       android:orientation="vertical">

       <Spinner

           android:id="@+id/WindowSpinner_3"

           android:layout_width="match_parent"

           android:layout_height="?attr/actionBarSize"/>

       <FrameLayout

           android:id="@+id/container_3"

           android:layout_width="match_parent"

           android:layout_height="match_parent">

       </FrameLayout>

   </LinearLayout>

   <LinearLayout

       android:id = "@+id/window_4"

       android:layout_width="200dp"

       android:layout_height="100dp"

       android:orientation="vertical">

       <Spinner

           android:id="@+id/WindowSpinner_4"

           android:layout_width="match_parent"

           android:layout_height="?attr/actionBarSize"/>

       <FrameLayout

           android:id="@+id/container_4"

           android:layout_width="match_parent"

           android:layout_height="match_parent">

       </FrameLayout>

   </LinearLayout>

</com.android.prog.CustomLayout>

класс CustomLayout.java:

public class CustomLayout extends LinearLayout {

public CustomLayout(Context context) {

   super(context);

}

public CustomLayout(Context context, AttributeSet attrs, int defStyleAttr, int defStyleRes) {

   super(context, attrs, defStyleAttr, defStyleRes);

}

public CustomLayout(Context context, AttributeSet attrs, int defStyleAttr) {

   super(context, attrs, defStyleAttr);

}

public CustomLayout(Context context, AttributeSet attrs) {

   super(context, attrs);

}

public void doSomefing{//Задаём действия с элементами внутри CustomLayout

}

}

Объяснение:

0,0(0 оценок)
Ответ:
филосов00
филосов00
20.01.2023 14:45

Если создать шаблон строки с автозаполнением, то можно немного у код:

import sys

num_steps = int(sys.argv[1])

fmt_template = '{}.{:>%d}' % num_steps

for x in range(1, num_steps + 1):

   print(fmt_template.format(x, '#' * x))

При num_steps = 4:

1.   #

2.  ##

3. ###

4.

Объяснение:

Все аргументы функции print, указанные через запятую, выводятся разделенные пробелом, отсюда и нестыковка.

Можно так попробовать:

for x in range(1, c+1):

   print('{0}{1}{2}'.format(x, " " * (c - x), '#' * x))

Для c = 3:

1  #

2 ##

3###

Либо заменить запятую конкатенацией (знак +):

print(str(x) + " " * (c - x) + '#' * x)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота