В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
gorlatenkoviktoria
gorlatenkoviktoria
01.07.2020 00:18 •  Информатика

Составить программу - конвертер, которая запрашивает тип единицы длины: 1 - дециметр, 2 - километр, 3 - метр, 4 - миллиметр, 5 - сантиметр, а также число - длину в этой единице и переводит данное число во все остальные единицы длины. ввод чисел заканчивается нажатием клавиши 0. протокол работы программы: выберите тип единицы длины: 1 - дециметр, 2 - километр, 3 - метр, 4 - миллиметр, 5 - сантиметр, 0- выход. 1 введите длину в этой единице: 5 ответ: 5 дм = 50 см = 500 мм = 0,5 м = 0,0005 км выберите тип единицы длины: 1 - дециметр, 2 - километр, 3 - метр, 4 - миллиметр, 5 - сантиметр, 0- выход. 3 введите длину в этой единице: 100 ответ: 100 м = 1000 дм = 10000 см = 100000 мм = 0,1 км выберите тип единицы длины: 1 - дециметр, 2 - километр, 3 - метр, 4 - миллиметр, 5 - сантиметр, 0- выход. 0 пока!

Показать ответ
Ответ:
princess82
princess82
07.10.2020 16:02
// PascalABC.NET 3.3, сборка 1600 от 23.12.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var r:integer;
  var x:real;
  while true do begin
    Write('Выберите тип единицы длины:',NewLine,
        '1-дециметр, 2-километр, 3-метр, 4-миллиметр, 5-сантиметр, 0-выход.' );
    Read(r);
    if r=0 then begin Writeln('Пока!'); Exit end;
    Write('Введите длину в этой единице: '); Read(x);
    case r of
      1:Writeln(x, ' дм = ',10*x,' см = ',100*x,' мм = ',x/10,' м = ',
            x/10000,' км');
      2:Writeln(x, ' км = ',1000*x,' м = ',10000*x,' дм = ',100000*x,' см = ',
            x*1000000,' мм');;
      3:Writeln(x, ' м = ',10*x,' дм = ',100*x,' см = ',x*1000,' мм = ',
            x/1000,' км');
      4:Writeln(x, ' мм = ',x/10,' см = ',x/100,' дм = ',x/1000,' м = ',
            x/1000000,' км');
      5:Writeln(x, ' cм = ',10*x,' мм = ',x/10,' дм = ',x/100,' м = ',
            x/100000,' км');
      end
    end
end.

Составить программу - конвертер, которая запрашивает тип единицы длины: 1 - дециметр, 2 - километр,
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота