Составить программу и её блок-схему используя одномерные массивы: Дано одномерный массив А, состоящий из N элементов. Посчитать максимальное количество подряд нулей. (Pascal)
Var a, b: integer; var c: string; begin writeln('Введите 1 число.'); readln(a); writeln('Введите 2 число.'); readln(b); writeln('Знак операции.'); readln(c); if c='*' then writeln(a*b); if c='/' then writeln(a/b); if c='-' then writeln(a-b); if c='+' then writeln(a+b); end. 2 ЗАДАЧА var a, b: real; begin writeln('Зарабаток Пети:'); readln(a); writeln('Зарабаток Петрова:'); readln(b); if a>b then writeln('Петя заработал больше Петрова.') else if a=b then writeln('Петров и Петя заработали одинаково.') else writeln('Петров заработал больше Пети.'); writeln('Среднее: ', (a+b)/2); end.
Привет всему 12 "А" классу(Реальному).Я знаю, зачем вы тут, и я вам Вы знаете меня, как Anxel09.
var a,b,sum,i : integer;
begin
readln(a,b);
if (a < 0) or (a > 10) then
while (a < 0) or (a > 10) do begin
writeln('Число ''a'' не подходит: ');
readln(a);
end;
if (b < 0) or ( b > 10) then
while (a < 0) or (a > 10) do begin
writeln('Число ''b'' не подходит: ');
readln(b);
end;
sum := 1;
for i:= 1 to b do
sum:= sum * a;
writeln('Число ''а'' в степени ''b''',' = ', sum );
end.
Вот и все!
Объяснение:
var c: string;
begin
writeln('Введите 1 число.');
readln(a);
writeln('Введите 2 число.');
readln(b);
writeln('Знак операции.');
readln(c);
if c='*' then writeln(a*b);
if c='/' then writeln(a/b);
if c='-' then writeln(a-b);
if c='+' then writeln(a+b);
end.
2 ЗАДАЧА
var a, b: real;
begin
writeln('Зарабаток Пети:');
readln(a);
writeln('Зарабаток Петрова:');
readln(b);
if a>b then writeln('Петя заработал больше Петрова.')
else if a=b then writeln('Петров и Петя заработали одинаково.')
else
writeln('Петров заработал больше Пети.');
writeln('Среднее: ', (a+b)/2);
end.