В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
ruzvelt3000
ruzvelt3000
08.09.2020 21:54 •  Информатика

Составить программу двумерного массива состоящую из 3 столбцов и 10 строк целых чисел. ввод осуществляется по формуле a[i,j]: =(a=1)/j+j

Показать ответ
Ответ:
ка566
ка566
07.10.2020 23:02
Const n=10; m=3;
var 
a:array[1..n,1..m] of real;
i,j:integer;
begin
for i:=1 to n do
 begin
 for j:=1 to m do
  begin
   a[i,j]:=(i+j)/j+j;
   write(a[i,j]:6:2);
  end;
  writeln;
 end;
end.

Результат:
 3.00 3.50 4.33
 4.00 4.00 4.67
 5.00 4.50 5.00
 6.00 5.00 5.33
 7.00 5.50 5.67
 8.00 6.00 6.00
 9.00 6.50 6.33
10.00 7.00 6.67
11.00 7.50 7.00
12.00 8.00 7.33
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота