Составить программу для выполнения суммы значений элементов массива a(n) не имеющие чётные индексы и произведение элементов этого массива. на паскале и без рандома.
Begin writeln('Введите первое число'); readln(a); writeln('Введите второе число'); readln(b);
if (a<0) and (b<0) then Begin a:=a+2; b:=b+2; writeln('a = ',a); writeln('b = ',b); end else if (a>0) and (b<0) then writeln('a*b = ',a*b) else if (a<0) and (b>0) then writeln('b-a = ', b-a)
Microsoft Word - это текстовый редактор от компании Microsoft. Программа обычно входит в пакет офисных программ Microsoft Office, но может поставляться и отдельно. Является платной и стоит просто бешеных денег для организаций (около 19000руб, т.к. продается только в составе пакета Microsoft Office Pro), и больших денег для домашних пользователей (около 4000р), но никого это не смущает, все используют пиратские версии. Программа позволяет редактировать тексты любой сложности, вставлять в документы картинки, таблицы и прочее нестандартное содержимое. Аналогом Microsoft Word является бесплатный Writer из пакета LibreOffice и OpenOffice, который позволяет делать всё то же самое, только бесплатно, хотя и немного сложнее местами. Microsoft Word официально работает только на компьютерах с ОС Microsoft Windows и Apple OS X, хотя возможен и его запуск на ОС семейства Linux через Wine, но корректная работа программы не гарантируется. Microsoft Word является самым распространенным текстовым редактором в мире.
uses crt;
var a,b:real;
Begin
writeln('Введите первое число');
readln(a);
writeln('Введите второе число');
readln(b);
if (a<0) and (b<0)
then
Begin
a:=a+2;
b:=b+2;
writeln('a = ',a);
writeln('b = ',b);
end
else
if (a>0) and (b<0)
then
writeln('a*b = ',a*b)
else
if (a<0) and (b>0)
then
writeln('b-a = ', b-a)
else writeln('Ни одно условие не выполняется');
readln;
end.