В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

Составить программу для вычисления значения функции y для заданного значения x у= если x< -3 то y= √1 - x² если 1,51,5, то y=tg x составить словесное описание алгоритма, составить блок схему, описать используемые элементы

Показать ответ
Ответ:
BOJl40K
BOJl40K
12.06.2020 08:19

var
x,y:real;
begin
readln(x);
if x<-3 then
y:=sqrt(1)-x*x
else if (x>=-3) and (x<=1.5) then
y:=1/(abs(x+2))
else if x>1.5 then
y:=sin(x)/cos(x);
writeln(y);
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота