В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
moyutot
moyutot
29.01.2021 21:51 •  Информатика

Составить программу для вычисления значения функции f(x)=x*cos(1/x)+2 на отрезке [a,b] с шагом h. результаты представить в виде таблицы (1-ый столбец - значения аргумента, 2- ой -значение функции).

Показать ответ
Ответ:
Karinarpro
Karinarpro
22.06.2020 17:19
Const
  n = 10;
 
var
  a,b,h,x: real;

begin
  writeln('a , b , h =');
  read(a, b, h);
  x := a - h;
  writeln('x':n, ' | ', 'y':n);
  repeat
    x := x + h;
    writeln(x:n:3, ' | ', (x * cos(1 / x) + 2):n:3);
   
  until x >= b;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота