В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
plplem9999
plplem9999
23.07.2021 13:54 •  Информатика

Составить программу для вычисления значений выражения: {x+1, если x=2 y= { {√x, если x=4

Показать ответ
Ответ:
5класс75
5класс75
04.09.2021 13:00
Const
  n=13;
var
  a:array[1..n] of integer;
  i,k,t:integer;
begin
  Randomize;
  Writeln('Исходный массив');
  for i:=1 to n do
    begin
    a[i]:=Random(21)-10;
    Write(a[i],' ')
    end;
  Writeln;
  { начало собственно программы }
  i:=1; k:=0;
  while (i<=n) and (k=0) do
    begin
    if a[i]=0 then k:=i;
    i:=i+1
    end;
  if k>0 then
    begin
    for i:=k to n-1 do a[i]:=a[i+1];
    Writeln('Массив-результат');
    for i:=1 to n-1 do Write(a[i],' ');
    Writeln
    end
  else
    Writeln('В массиве нет нулевых элементов')
end.

Контрольное решение
Исходный массив
6 -6 10 -9 6 9 0 10 6 0 -10 -3 6
Массив-результат
6 -6 10 -9 6 9 10 6 0 -10 -3 6
0,0(0 оценок)
Ответ:
George6666666
George6666666
10.02.2023 18:58
Применение информационных технологий

Сегодня нет такой сферы производства и хозяйствования, в которых бы не применялись информационные технологии. С информационных технологий осуществляется успешная деятельность множества компаний, которые занимаются производством той или иной продукции.

Информационные технологии и компьютеризация позволяют усовершенствовать и облегчить производственный процесс, а полная или частичная его автоматизация позволяет облегчить труд, связанный с выполнением опасных для жизни трудовых действий.

Также, информационные технологии применяются для того, чтобы удовлетворять непроизводственные потребности общества.

Так, допустим, сегодня информационные технологии массово применяются в образовании. Они формировать независимую информационную личность, учат принимать правильное решение и эффективно использовать информационные ресурсы. Информационные технологии в образовании подготавливают человека, который легко, оперативно и эффективно обрабатывать данные и применять компьютерные возможности на практике.

В туризме, допустим, информационные технологии применяются с целью облегчить процесс формирования тура и организации отдыха. С информационных технологий туроператор может легко и быстро наладить коммуникационные связи с объектами, которые, непосредственно, принимают участие в создании отличных условий отдыха. Также, с информационных технологий и техники появляется у человека возможность интернет-бронирования авиабилетов и многое другое.

В сфере производства информационные технологии применяются с целью не только облегчить труд работников и уменьшить их численность, а и позволяют осуществлять процесс производства быстрее, производя большие объемы продукции.

Сегодня информационные технологии позволяют решать много проблем и предоставляют возможность сделать мир современнее, лучше, удобнее и комфортнее. 
  
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота