В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Misani
Misani
01.05.2022 13:40 •  Информатика

Составить программу для вычисления значений функции y=f(x) в точках от х=х1 до х=хn c шагом Δх. При выполнении задания использовать операторы цикла с постусловием, с предусловием и оператор цикла с параметром.


Составить программу для вычисления значений функции y=f(x) в точках от х=х1 до х=хn c шагом Δх. При

Показать ответ
Ответ:
AlikhanKazbekov
AlikhanKazbekov
23.03.2020 14:50

Ирина и Тимур = не информатика 

Таня и Саша = не информатика 

Тимур = боится физики 

Таня, Тимур = не литература, но плавают 

Тимур и Таня = поздравили математика 

Ирена = cожалеет мало времени на литературу

победители по: физике, математике, информатике, литературе и географии.

Коля -  информатика (Ирена и Тимур = учит, Камилла и Эльдар = интересуются) 

Тимур - не физика, не литература, не математика, не информатика, 

значит география 

Таня - не информатика, не литература, не математика, уже не география => Физика 

Ирена - не информатика, не физика, не география => Литература 

Коля - Математика

0,0(0 оценок)
Ответ:
irina707
irina707
01.09.2020 02:08
// PascalABC.NET 3.0, сборка 1156 от 30.01.2016
function Avg(a:array[,] of integer):real;
begin
  var s:=0; var k:=0;
  foreach var e:integer in a do
    if e>0 then begin s+=e; Inc(k) end;
  if k>0 then Result:=s/k else Result:=1e-100;
end;

begin
  var A:=MatrixRandom(4,4,-50,50); Writeln(A);
  Writeln('Среднее арифметическое положительных равно ',Avg(A):0:3);
  var B:=MatrixRandom(5,5,-30,30); Writeln(B);
  Writeln('Среднее арифметическое положительных равно ',Avg(B):0:3);
  var C:=MatrixRandom(4,5,-25,38); Writeln(C);
  Writeln('Среднее арифметическое положительных равно ',Avg(C):0:3);
end.

Тестовое решение:
[[35,35,5,-47],[14,34,35,-13],[25,-5,35,-29],[-7,10,-12,12]]
Среднее арифметическое положительных равно 24.000
[[-12,-17,-10,19,14],[20,17,-27,-2,16],[-3,-21,30,2,10],[5,-3,-17,-3,18],[0,-26,29,1,-22]]
Среднее арифметическое положительных равно 15.083
[[-5,-11,17,-4,15],[15,17,-24,36,15],[-8,-3,-22,28,-25],[-21,6,12,31,-1]]
Среднее арифметическое положительных равно 19.200
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота