В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
hamkochan
hamkochan
25.08.2020 03:29 •  Информатика

Составить программу для вычисления значений функции y = f(x) при
произвольных значениях x. (a, b – константы) javascript

Показать ответ
Ответ:
Снежана341
Снежана341
18.11.2022 11:43

Дан массив, содержащий 70 целых чисел. Опишите на одном из языков программирования алгоритм,

позволяющий найти и вывести наименьшее содержащееся в массиве положительное число, десятичная

запись которого оканчивается цифрой 7. Гарантируется, что в массиве есть хотя бы один

положительный элемент, десятичная запись которого оканчивается цифрой 7. Исходные данные объявлены так, как показано ниже. Запрещается использовать переменные, не описанные ниже, но

разрешается не использовать часть из них.

1

2

3

4

5

6

7

8

9

const N=70;

var

a: array [1..N] of integer;

i, j, m: integer;

begin

for i:=1 to N do

что-то подобное?

0,0(0 оценок)
Ответ:
Tvoy1Batya
Tvoy1Batya
19.11.2020 16:02
1. Современный вариант

// PascalABC.NET 3.1, сборка 1213 от 04.04.2016
begin
  var a:=ArrRandom(ReadInteger('n='),10,99); a.Println;
  a:=a.Reverse.ToArray; a.Println
end.

Тестовое решение:
n= 15
33 91 99 60 56 92 99 23 33 25 62 27 42 27 11
11 27 42 27 62 25 33 23 99 92 56 60 99 91 33

2. Школьный вариант

// PascalABC.NET 3.1, сборка 1213 от 04.04.2016
const
  n=15;
var
  a:array[1..n] of integer;
  i,t:integer;
begin
  Randomize;
  for i:=1 to n do begin
    a[i]:=Random(90)+10;
    Write(a[i],' ')
    end;
  Writeln;
  for i:=1 to n div 2 do begin
    t:=a[i]; a[i]:=a[n-i+1]; a[n-i+1]:=t
    end;
  for i:=1 to n do Write(a[i],' ')
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота