В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

Составить программу для вычисления значений функции . Аргумент функции x изменяется от -6 до 10 c шагом 1.
Вывести в окно результатов только положительные значения функции.

Показать ответ
Ответ:
dghakdkc
dghakdkc
23.02.2023 22:27

Итак. Мы имеем строку из 72 пятерок.

Сначала все пятерки заменяются на тройки (приоритетным действием у нас является замена первого вхождение трех идущих подряд пятерок тройками, а т.к. 72 кратно трем, то преобразованная строка будет состоять только из троек). После этого у нас остается строка, состоящая из 24 троек.

555 555 555 555 ... 555 => 333 333 333 333 333 333 333 333

Затем происходят такие действия: три последовательно идущие тройки заменяются на пятерки, а после того как таких пятерок будет три, они заменятся на одну тройку. Следственно 9 троек заменяются на одну. После проведение данных действий у нас остается 24-9+1-9+1=16-9+1=8 троек.

333 333 333 333 333 333 333 333

555 333 333 333 333 333

333 333 333 333 333 3

555 333 333 3

333 333 33

Так как мы уже не можем получить заменой троек хотя бы три пятерки, то первые вхождения трех подряд идущих троек заменяются пятерками.

333 333 33

5 333 33

5533

ответ: 5533

0,0(0 оценок)
Ответ:
innaalekseenko1
innaalekseenko1
22.10.2020 02:55
Паскаль АВС:

Program Ikiru;
uses crt;
var
  y,x:real;
begin
  writeln('*** Alphaeus is thinking... ***');
  writeln('***          OK             ***');
  writeln(); writeln();
    write('Введите Х '); readln(x);
    if (sin(3*x)=0) or (ln(1+x*x)=0) or (cos(x)<=0)
      then
        writeln('Функция Y для этого значения Х не определена')
      else
        begin
          y:=2*(cos(3*x)/sin(3*x))-ln(cos(x))/ln(1+x*x);
          writeln('y=',y:8:2);
        end;
end.

Пояснения:
write('Введите Х '); readln(x);
  - программа просит пользователя ввести х
if (sin(3*x)=0) or (ln(1+x*x)=0) or (cos(x)<=0)
  - проверка существования функции (функция ctgХ не существует, если sinX=0, ln берется только от неотрицательных значений, в знаменателе дроби не может быть 0)
Если хотя бы одно из условий не выполняется,  выводится ссобщение о том, что функция для этого значения не определена.
Если все проверки пройдены, программа вычисляет значение функции Y и выводит его на экран.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота