В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Gazizianov2018
Gazizianov2018
16.05.2022 16:51 •  Информатика

Составить программу для вычисления суммы и среднего арифметического значения всех элементов заданного одномерного массива а, состоящего из 10-ти элементов. на языке с#

Показать ответ
Ответ:
unikornio
unikornio
08.07.2020 14:34

Все слова/анаграммы, которые можно составить из слова "сканер"

Из "сканер" можно составить 58 слов из 2,3,4,5 букв.

Слова из 2 букв, составленные из комбинации "сканер" (12 слов):

ан ар ас ер ка кн кр на не нс ре се

Слова из 3 букв, составленные из комбинации "сканер" (22 слова):

акр аре арк аск ера кар кеа кен кер кнр нар нас нес рак рен рнк сак сан сен сер сна сне

Слова из 4 букв, составленные из комбинации "сканер" (13 слов):

акне енка каре керн крае кран крен раек река саек саке сена сера

Слова из 5 букв, составленные из комбинации "сканер" (11 слов):

аксен анкер аскер кенар нарек насек нерка серка серна скарн скена

0,0(0 оценок)
Ответ:
ikaerlapova
ikaerlapova
01.02.2023 17:28
Program pr;
uses crt;

Var mas:array[1..1000, 1..1000] of integer;
N,M,i,j,k:integer;

Begin
Writeln('Введите размер матрицы N*M');
Write('N = ');
readln(N);
Write('M = ');
readln(M);

if (M>1000) or (N>1000) or (M<1) or (N<1)
then  
Writeln('Ошибка, указанные значения выходят за пределы матрицы')   else   
        Begin      
 Writeln('Введите элементы матрицы');      

k:=0; 
 for i:=1 to N do     
  for j:=1 to M do     
    Begin     
      readln(mas[i,j]);       
      if (mas[i,j] mod 2 = 0) then k:=k+1;     
    end; 
  
    Writeln();   
    Writeln('Исходная матрица');
   
   for i:=1 to N do   
     Begin     
       for j:=1 to M do     
          Begin     
             Write(mas[i,j], ' ')     
           end;     
      Writeln();   
     end;         

Writeln();   
Writeln('Количество четных элементов = ',k);      
 end;

readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота