В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Люсик20
Люсик20
21.03.2021 19:20 •  Информатика

Составить программу для вычисления работы сердца А=1,2V(Р+DC2 /2). В норме
ударный объем сердца– Vудар =6*10-5
м3
, среднее артериальное давление P= 13000 Па,
плотность крови D = 1.05*103 кг/м3 ,скорость потока крови С = 0.5 м/с. Если, при
заданных параметров результат будет равен А= 0.94545 жоуль, программа составлена.

Показать ответ
Ответ:
илрлрле
илрлрле
17.05.2021 17:49
// PascalABC.NET 3.1, сборка 1219 от 16.04.2016
begin
  var a:=ReadLines('m17.txt').JoinIntoString.ToIntegers;
  a.Println;
  var b:=a.Select((x,i)->Rec(x,i)).Where(x->x.Item1<0)
    .Select(x->x.Item2).ToArray;
  if b.Count<>2 then
    Writeln('Количество отрицательных элементов не равно двум')
  else begin
    a:=SeqFill(b[0],0).Concat(a.Skip(b[0]).Take(b[1]-b[0]+1))
      .Concat(SeqFill(a.Length-b[1]-1,0)).ToArray;
    a.Println
    end
end.

Тестовое решение:
23 14 7 15 0 13 -6 41 18 13 8 42 27 -11 3 19 10
0 0 0 0 0 0 -6 41 18 13 8 42 27 -11 0 0 0

Файл с исходными данными имеет имя m17.txt. Тестовый файл находится во вложении. Разбивка на строки сделана по 5 значений, но может быть совершенно произвольной. Также нет привязки именно к 17 числам, главное - чтобы отрицательных чисел было ровно два, иначе будет выдано сообщение о их неверном количестве.
0,0(0 оценок)
Ответ:
Натали2004абвг
Натали2004абвг
24.04.2023 17:01
Сумма всех четных чисел от 1 до 200 - это на самом деле сумма чисел
2+4+6+...+198+200.

1. Самый короткий вариант

// PascalABC.NET 3.1, сборка 1219 от 16.04.2016
begin
  Writeln(Range(2,200,2).Sum)
end.

Результат:
10100

2. Более длинный и более "школьный" вариант

// PascalABC.NET 3.1, сборка 1219 от 16.04.2016
begin
  var s:=0;
  var i:=2;
  while i<=200 do begin
    s:=s+i;
    i:=i+2
    end;
  Writeln(s)
end.

3. Совсем "тупой школьный" вариант (решение "в лоб")

// PascalABC.NET 3.1, сборка 1219 от 16.04.2016
var
  i,s:integer;
begin
  s:=0;
  for i:=1 to 200 do
    if i mod 2 =0 then s:=s+i;
  Writeln(s)
end.

4. Улучшенный "школьный" вариант

// PascalABC.NET 3.1, сборка 1219 от 16.04.2016
var
  i,s:integer;
begin
  s:=0;
  for i:=1 to 100 do s:=s+2*i;
  Writeln(s)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота