В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
aRikKira05
aRikKira05
03.07.2021 17:34 •  Информатика

Составить программу для turbo pascal. дано 2 круга с общим центром и радиусами r1 и r2 (r1> r2).найти площадь этих кругов s1 и s2,а также площадь кольца s3 ,наружный радиус которого равен r1,а внутренний радиус равен r2 ; s1=п(r1)^2, s2=п(r2)^2, s3=s1-s2. значение п=3.14

Показать ответ
Ответ:
Elizabeth041100
Elizabeth041100
01.10.2020 06:23

Program irinagavrish;
const
  pi = 3.14;
Var
  r1,r2,s1,s2,s3:real;
begin
  writeln('*** alphaues is thinking... ***');
  writeln('***          OK             ***');
  writeln();
  write('Введите радиус первой окружности: ');readln(r1);
  write('Введите радиус второй окружности: ');readln(r2);
  s1:=pi*r1*r1;
  s2:=pi*r2*r2;
  s3:=abs(s1-s2);
  writeln('Площадь первого круга: ',s1:7:2);
  writeln('Площадь второго круга: ',s2:7:2);
  writeln('Площадь кольца: ',s3:7:2);
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота