В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
aryka2
aryka2
25.02.2020 09:45 •  Информатика

Составить программу для решения : "ввести число, обозначающее размер одной фотографии в мбайтах. определить, сколько фотографий поместится на флэш-карту объёмом 2 гбайта." язык программирования: pascal

Показать ответ
Ответ:
vladpaskevits
vladpaskevits
06.10.2020 00:24
1. С вещественными числами

var
  k:real;
begin
  Write('Размер фотографии, мб: '); Read(k);
  Writeln('На flash-card объемом 2 Гб поместится фото: ',
    Trunc(2*1024/k))
end.

Пример
Размер фотографии, мб: 3.27
На flash-card объемом 2 Гб поместится фото: 626

2. С целыми числами

var
  k:integer;
begin
  Write('Размер фотографии, мб: '); Read(k);
  Writeln('На flash-card объемом 2 Гб поместится фото: ',2*1024 div k)
end.

Пример
Размер фотографии, мб: 3
На flash-card объемом 2 Гб поместится фото: 682
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота