Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
Pahamoseuv
10.06.2022 22:12 •
Информатика
Составить программу для решения квадратного уравнения a*x*x+b*x+c=0
Показать ответ
Ответ:
LetMaria
07.10.2020 10:17
Var
a, b, c, D: integer;
x, x2: real;
begin
write('Введите a: ');
readln(a);
write('Введите b: ');
readln(b);
write('Введите c: ');
readln(c);
D := sqr(b) - 4 * a * c;
if D > 0 then begin
x := (-b - sqrt(D)) / 2 * a;
x2 := (-b + sqrt(D)) / 2 * a;
writeln('x1 = ', x, newline, 'x2 = ', x2);
end;
if D < 0 then writeln('Корней нет.');
if D = 0 then begin
x := (-b) / 2 * a;
writeln('x = ', x);
end;
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
anastasiya264
29.08.2022 07:08
Выполнить сортировку только четных элементов массива(нечетные элементы остаются на своих местах)...
bakulya2005ma
29.08.2022 07:08
Идентификатор, позволяющий именовать некоторый оператор программы. (5 букв)...
Brozuca
30.07.2022 04:40
Какой телефон предоставляет стабильную связь и работает на протяжении 10 лет. Недостатком является его привязанность к одному месту??? ...
цветочек751
29.01.2021 02:56
1. Дана длина комнаты в миллиметрах. Выразите длину в метрах, сантиме- трах и миллиметрах. Например, 6542 мм= 6 метр 54 см 2 мм. ИНФОРМАТИКА ...
54Азиз
11.03.2020 13:49
на С++ написать программу, которая выводит заданное число на экран, а также сумму и произведение его цифр....
ученик6В1
22.07.2021 23:10
Составьте схему которая продемонстрирует хранение файлов на диске...
laravivaldyoy2w4w
03.10.2021 03:39
Презентация на тему Лена и детская площадка из Янд. учебника...
Miliosha
03.03.2022 11:47
Какой тип данных будет при операциях */, +, **? Можно ли изменить тип данных?...
Наполнение
12.11.2021 22:08
Выбрать Море, Площадь тыс. км2. Объем км3 где Тип моря - “Материково-окраинное или Тип моря “Море-озеро ...
pe4enel
06.05.2023 16:57
Терміново, до ть, будь ласка. Один майстер може виконати роботу за t1 годин, другий майстер - за t2 годин. Знайти за скільки годин можуть виконати роботу обидва майстра...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
a, b, c, D: integer;
x, x2: real;
begin
write('Введите a: ');
readln(a);
write('Введите b: ');
readln(b);
write('Введите c: ');
readln(c);
D := sqr(b) - 4 * a * c;
if D > 0 then begin
x := (-b - sqrt(D)) / 2 * a;
x2 := (-b + sqrt(D)) / 2 * a;
writeln('x1 = ', x, newline, 'x2 = ', x2);
end;
if D < 0 then writeln('Корней нет.');
if D = 0 then begin
x := (-b) / 2 * a;
writeln('x = ', x);
end;
end.