В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

Составить программу для проверки утверждения: «Результатами вычислений по формуле х2 + х + 17 при 0 больше или равно х больше или равно 15 являются простые числа». Все результаты вывести на экран.

Показать ответ
Ответ:
denisdudkin739
denisdudkin739
13.06.2022 23:20
N = 2^{i}
i - кол-во бит
N - мощность (кол-во всех возможных вариаций)
Корабль передаёт либо длинный, либо короткий значит может принимать всего 2 состояния. Он отправляет 6 сигналов (3 коротких 3 длинных) Значит код-во возможных вариаций расстановок этих сигналов будет равна 2^{6}
Подставим в формулу
2^{6} = 2^{i}
Следовательно i  = 6
Кол-во бит информации - 6
ответ: 6
///////////////////////////////////////////////////////
А вообще для таких задач я использую такую формулу
log_{2}K = i
K - сколько всего может быть исходов, i - кол-во бит

Корабль может передавать либо короткий, либо длинный сигнал. Значит кол-во состояний - 2
Он передаёт 3 коротких и 3 длинных, значит всего - 3+3 = 6
кол-во всех возможных исходов при 6 сигналах и кол-во состояний будет равно 2^{6}
Если ты понимаешь суть логарифма, то ответ уже думаю тебе ясен, если нет, то читай дальше :)
Подставляем в нашу формулу кол-во возможных событий
log_{2}( 2^{6}) = i
логарифм по основанию a, это значит надо найти такою степень числа a, при возведении в которую получится число, которое в выражении логарифма, а так как мы в логарифме по основанию 2 возводим число 2, то тут и вычислять нечего. Просто пишем степень двойки.
Это число 6.
0,0(0 оценок)
Ответ:
Владислава3188125
Владислава3188125
02.09.2020 06:34
Const
    n = 10;

var
    i, c: integer;
    a, w: array[1..n] of integer;

begin
    randomize;
    
    writeln('Исходный массив:');
    for i := 1 to n do
    begin
        a[i] := random(201) - 100;
        write(a[i], ' ');
    end;
    writeln;
    
    c := 0;
    for i := 1 to n do
        if a[i] > 0 then
        begin
            c := c + 1;
            w[c] := a[i];
        end;
    
    writeln('Кол-во положительных элементов: ', c);
    for i := 1 to n do
    begin
        if a[i] <= 0 then
        begin
            c := c + 1;
            w[c] := a[i];
        end;
    end;
    
    writeln('Результат:');
    for i := 1 to c do
        write(w[i], ' ');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота