В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Iriska91l23
Iriska91l23
07.06.2023 11:20 •  Информатика

Составить программу для нахождения значения выражения: k=10n3+5m2
,

Показать ответ
Ответ:
karinasurshkose
karinasurshkose
23.09.2022 03:03
101001001 010110101 101001010 0101001010 101010100 0101001010 0110011101001001 010110101 101001010 0101001010 101010100 0101001010 0110011101001001 010110101 101001010 0101001010 101010100 0101001010 0110011101001001 010110101 101001010 0101001010 101010100 0101001010 0110011101001001 010110101 101001010 0101001010 101010100 0101001010 0110011101001001 010110101 101001010 0101001010 101010100 0101001010 0110011101001001 010110101 101001010 0101001010 101010100 0101001010 0110011101001001 010110101 101001010 0101001010 101010100 0101001010 0110011101001001 010110101 101001010 0101001010 101010100 0101001010 0110011101001001 010110101 101001010 0101001010 101010100 0101001010 0110011
101001001 010110101 101001010 0101001010 101010100 0101001010 0110011101001001 010110101 101001010 0
0,0(0 оценок)
Ответ:
FenniXDouble
FenniXDouble
11.06.2022 04:52

Відповідь:

import random

def printer(matr):

   for l in matr:

       print(*l,sep = "\t")

n = int(input("Введите порядок матрицы:\n"))

k = int(input("Введите строку для поиска её минимума:\n"))

matrix = []

for i in range(n):

   t=[]

   for j in range(n):

       t.append(random.randint(0,100))

   matrix.append(t)

print("Исходная матрица:\n")

printer(matrix)

k_min = min(matrix[k-1])

print(f"Минимальный элемент строки {k} равен {k_min}\n")

for i in range(n):

   for j in range(n):

       print(f"Элемент [{i+1},{j+1}]: {k_min}*{matrix[i][j]} = {matrix[i][j]*k_min}")

       matrix[i][j]*=k_min

print("Окончательная матрица:\n")

printer(matrix)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота