В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
lycena
lycena
09.11.2021 06:54 •  Информатика

Составить программу для нахождения всех натуральных решений уравнения i2 + j2 = k2 в интервале [1, 10]. Решения, которые получаются перестановкой n и m, считать совпадающими.

Показать ответ
Ответ:
poldin04
poldin04
21.11.2021 22:52

var a, b, c, d, min, max: integer;

begin

 // Min

 readln(a, b, c, d);

 if (a <= b) and (a <= c) and (a <= d) then min := a

 else if (b <= a) and (b <= c) and (b <= d) then min := b

 else if (c <= a) and (c <= b) and (c <= d) then min := c

 else if (d <= a) and (d <= b) and (d <= c) then min := d;

 // Max

 if (a >= b) and (a >= c) and (a >= d) then max := a

 else if (b >= a) and (b >= c) and (b >= d) then max := b

 else if (c >= a) and (c >= b) and (c >= d) then max := c

 else if (d >= a) and (d >= b) and (d >= c) then max := d;

   

 writeln('Min: ', min);

 writeln('Max: ', max);

end.

0,0(0 оценок)
Ответ:
Anastasia12578
Anastasia12578
23.02.2022 13:11

1 программа:

var x, y, t:integer;

begin

 for x:=3 to 15 do begin

   writeln('x = ', x);

   t := x - 2;

   y := 7*t*3-6*t+10;

   writeln('y = ', y);

   writeln('');

 end;

end.

2 программа:

const pass ='45xlua';

var x:string;

a:boolean;

begin

 a:= false;

 while a<>true do begin

    writeln('Введите пароль');

    readln(x);

    if x = pass then begin

      a:=true;

      writeln('Пароль верный');

      end

    else

      writeln('Пароль неверный, введите еще раз');

    writeln('');

 end;

end.

4 программа:

var a, a1, a2, x, kol:integer;

begin

writeln('Введите четырёхзначное число');

readln(a);

x := a;

while x<>0 do begin

  x:= x div 10;

  kol:= kol + 1;

  end;

 if (kol = 4) then begin

   a1 := a div 100;

   a2:= a mod 100;

   writeln(a1+a2);

 end

  else

    writeln('Число не является четырёхзначным');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота