В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

Составить программу для нахождения произведение чисел от 1 до n. для циклов: 1)for 2)while 3)until

Показать ответ
Ответ:
Diron2004
Diron2004
22.09.2020 18:47
//Pascal
var
  a, p:  word;
  i, n: integer;

begin
  readln(n);
  //цикл for
  p := 1;
  for i := 1 to n do
    p := p * i;
  writeln(p);
 
  //цикл while
  i := 1;
  p := 1;
  while i <= n do
  begin
    p := p * i;
    i := i + 1;
  end;
  writeln(p);
 
  //цикл repeat
  i := 1;
  p := 1;
  repeat
    p := p * i;
    i := i + 1;
  until i > n;
  writeln(p);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота