В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
dilya091
dilya091
06.04.2020 11:05 •  Информатика

составить программу. "Дано число (вводится пользователем с клавиатуры). Если число делится на 3 или оканчивается на 7, то вывести сообщение: Число удовлетворяет условию. В противном случае вывести сообщение: Заданное число не соответствует условию." язык - Паскаль

Показать ответ
Ответ:
qwertzasd
qwertzasd
31.12.2020 15:37
// PascalABC.NET 3.0, сборка 1073
const
  nn=30;
  mm=30;
var
  a:array[1..mm,1..nn] of integer;
  m,n,i,j,k,s:integer;
begin
  Writeln('Введите число строк и столбцов массива: '); Read(m,n);
  Randomize;
  Writeln('*** Исходный массив ***');
  k:=0;
  for i:=1 to m do begin
    for j:=1 to n do begin
      a[i,j]:=Random(51)-25;
      Write(a[i,j]:4);
      if Odd(a[i,j]) then Inc(k)
    end;
    Writeln
  end;
  if k>5 then begin
    Writeln('Средние арифметические отрицательных элементов по строкам');
    for i:=1 to m do begin
      s:=0; k:=0;
      for j:=1 to n do
        if a[i,j]<0 then begin Inc(k); s:=s+a[i,j] end;
      if k>0 then Writeln(s/k:9:5) else Writeln('  0.00000');
    end
  end
  else begin
    Writeln('*** Результирующий массив ***');
    for i:=1 to m do begin
      for j:=1 to n do begin a[i,j]:=2*a[i,j]; Write(a[i,j]:4) end;
    Writeln
    end
  end
end.

Тестовые решения:
Введите число строк и столбцов массива:
8 6
*** Исходный массив ***
 -16  -8  -1  24 -22   1
  -9 -20 -25  13 -11  10
 -15  10 -12  20 -22   3
  -6  25  -3  25 -14  22
  24  -4  24  17  -4 -17
 -23  -9 -22   1 -18 -13
 -12  13   6 -16   2 -13
  19   8 -22  14  -3   4
Средние арифметические отрицательных элементов по строкам
-11.75000
-16.25000
-16.33333
 -7.66667
 -8.33333
-17.00000
-13.66667
-12.50000

Введите число строк и столбцов массива:
3 5
*** Исходный массив ***
   3  24 -21 -22  -8
 -21  14 -22   0 -22
  15 -16  -2   6  22
*** Результирующий массив ***
   6  48 -42 -44 -16
 -42  28 -44   0 -44
  30 -32  -4  12  44
0,0(0 оценок)
Ответ:
Алёнаум1
Алёнаум1
21.01.2021 19:32
//Pascal ABC.NET v3.1 сборка 1172

type
 re=Record
  name:string;
  res:integer;
 end;

 Const
 n=3;

Var
 ar:array[1..n] of re;
 i,j,c:integer;
 cs:string;
begin;
for i:=1 to n do
 begin
  write('Введите имя участника №',i,':');
 readln(ar[i].name);
  write('Введите результат участника №',i,':');
 readln(ar[i].res);
 end;
 for i:=1 to n-1 do
  for j:=i to n do
  if ar[i].res>ar[j].res then
   begin;
   c:=ar[i].res;
   ar[i].res:=ar[j].res;
   ar[j].res:=c;
   cs:=ar[i].name; 
  ar[i].name:=ar[j].name;
   ar[j].name:=cs;
   end;for i:=1 to n do
writeln(i,' ',ar[i].name,' ',ar[i].res);
end.

Пример ввода:
Двачевская
23
Персунов
22
Хацуне
3
Пример вывода:
1 Хацуне 3
2 Персунов 22
3 Двачевская 23
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота