В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Chcdhj
Chcdhj
26.06.2021 00:41 •  Информатика

Составить программный код, нужно сделать до завтра. будет на скрине.

Показать ответ
Ответ:
д54
д54
02.06.2023 02:24

Вот программа, довольно понятная, 

комментарии:

lepestkov:=13; - тут можно менять количесто лепестков

fi:=2*3.14*i/lepestkov;

2*Pi - это полный угол 360 градусов. мы делим его на количество лепестков. Таким образом мы получаем угол на который должен идти лепесток.

 

Картинка ромашки во вложении. если такая не пойдет, отмечай как нарушение.

 

uses crt, graph;
var gDriver, gMode, errCode:integer;
i:integer;
lepestkov:integer;
fi,x,y:real;
radius:integer;
begin
gDriver:=Detect;
InitGraph(gDriver, gMode,'');
ErrCode:=GraphResult;
if(GraphResult <> grOK) then
begin
writeln('ne mogu naiti file graphiki');
readln;
end;
setcolor(green);
line(320,200,320,400);
setcolor(yellow);
setFillStyle(SolidFill, yellow);
fillellipse(320,200,15,15);
setFillStyle(SolidFill, white);
setcolor(white);
lepestkov:=13;
for i:=1 to lepestkov do
begin
fi:=2*3.14*i/lepestkov;
for radius:=24 to 60 do
begin
x:=320 + radius*cos(fi);
y:=200 + radius*sin(fi);
fillellipse(round(x),round(y),10,10);
end;
end;
readln;
end.


Составить программу рисования ромашки на паскале.
0,0(0 оценок)
Ответ:
Beknazarova02
Beknazarova02
03.06.2022 02:25
Код Pascal 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 uses crt; var s1,s2,z1,z2:string;     i:integer; begin z1:='Минск столица Беларуси'; z2:='Беларусь ты моя синеокая';   writeln('Dana stroka: '); writeln(z1); s1:=''; s2:=''; i:=1; while z1[i]<>' ' do       begin       s1:=s1+z1[i];       inc(i);       end; i:=length(z1); while z1[i]<>' ' do       begin       s2:=z1[i]+s2;       dec(i);       end; delete(z1,1,length(s1)); delete(z1,length(z1)-length(s2)+1,length(s2)); write (s2,z1,s1); writeln; writeln('Dana stroka: '); writeln(z2); s1:=''; s2:=''; i:=1; while z2[i]<>' ' do       begin       s1:=s1+z2[i];       inc(i);       end; i:=length(z2); while z1[i]<>' ' do       begin       s2:=z2[i]+s2;       dec(i);       end; delete(z2,1,length(s1)); delete(z2,length(z2)-length(s2)+1,length(s2)); write (s2,z2,s1); readln; end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота