В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

Составить блок-схему для решения задачи и написать программу с протоколом решения: Задача: Вычислить сумму 1/n3 для n=1,2,40.

Показать ответ
Ответ:
Ониг
Ониг
12.09.2022 12:41

В первой четверти (x > 0, y > 0) заштрихована четверть окружности с началось в центре координат и радиусом 6. Уравнение этой окружности x^2+y^2=36, тогда точка попадает в заштрихованную область, если x^2+y^2. Сюда же можно добавить и отрезок от 0 до 6 по оси абсцисс.

В четвертой четверти (x > 0, y < 0) заштрихован треугольник. Граница проходит через точки (0, -6) и (6, 0), уравнение - линейная функция y = x - 6. Сюда будут попадать точки, для которых y > x - 6.

Собираем условия вместе и можно писать программу.

Код (PascalABC.NET):

begin

 var (x, y) := ReadReal2;

 if (x > 0) and (y >= 0) and (x * x + y * y < 36) then

   write('true')

 else if (x > 0) and (y < 0) and (y > x - 6) then

   write('true')

 else

   write('false')

end.

Код (Python 3):

x, y = map(float, input().split())

if x > 0 and y >= 0 and x * x + y * y < 36:

   print('true')

elif x > 0 and y < 0 and y > x - 6:

   print('true')

else :

   print('false')

Пример ввода:

3 5

Пример вывода:

true

0,0(0 оценок)
Ответ:
СилаЛебедя
СилаЛебедя
06.07.2021 23:49

(A & B) & (C v D)​ = 0 (ложь)

Объяснение:

А = {Принтер — устройство ввода информации} = 0 (ложь, т.к. принтер — устройство вывода информации)

В = {Процессор — устройство обработки информации} = 1 (истина, т.к. процессор — устройство обработки информации)

С = {Монитор — устройство хранения информации} = 0 (ложь, т.к. монитор — устройство вывода информации)

D = {Клавиатура — устройство ввода информации} = 1 (истина, т.к. клавиатура — устройство ввода информации)

(A & B) & (C v D)​ = (0 & 1) & (0 v 1)​ = 0 & 1​ = 0 (ложь)

И (&) - истинно, когда оба исходных высказывания истинны

ИЛИ (∨) - ложно, когда оба исходных высказывания ложны

Здесь в первую очередь выполнили действия в скобках

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота