В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
dgostishev
dgostishev
08.06.2023 14:23 •  Информатика

Составить алгоритмы и программы длясоставить алгоритмы и программы для заполнения : массива а (30) по формуле a(i) = 10*i + 2*i2. найти среднее арифметическое элементов < 50. распечатать массив в строку. составьте программу

Показать ответ
Ответ:
MasterDrenZik
MasterDrenZik
25.06.2020 15:42
Если я правильно понял условие, то код выглядит так.
uses crt;
var i,ans,sum:integer;
a:array[1..30] of integer;
begin
sum:=0;
ans:=0;
for i:=1 to 30 do
begin
a[i]:=10*i+2*sqr(i);
if a[i]<50 then
ans:=ans+1;
sum:=sum+a[i];
end;
writeln(sum/ans);
for i:=1 to 30 do
write(a[i],' ');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота