В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
jakupbekova860
jakupbekova860
13.06.2020 19:13 •  Информатика

Составить алгоритм и написать программу, которая печатает "столбиком":

третьи степени всех целых чисел от а до 50 (значение а вводится с клавиатуры; а ≤ 50);

Показать ответ
Ответ:
Милка534535
Милка534535
21.03.2021 15:59

Серёжа разлил краску

Объяснения:

Учительница знала, что один из её учинеков, назовём его правдивым, оба раза сказал правду; второй, назовём его шутником, оба раза сказал неправду; третий, назовём его хитрецом, один раз сказал правду, а другой раз — неправду.

Назовите имена правдивого, шутника и хитреца. Кто из участников пролил краску

Пусть К= «Коля разбил вазу», В= «Вася разлил краску» , С= «Серёжа разлил краску» . Для решения задачи можно составить таблицу истинности, в которой представить высказывания каждого мальчика. Так как краска разлита одним учинеков, то чтобы выяснить, кто именно это сделал, достаточно фрагмента таблицы истинности, содержащего наборы значений входных переменных:

Исходя из того, что знает о учинеках учительница , следует искать в таблице строку, содержащую в каком-либо порядке три комбинации значений: 00 (слова шутника), 11 (слова правдивого учинека), 01 или 10 (слова хитреца). Краску розлил Серёжа, он же оказался хитрецом. Шутником оказался Вася. Имя правдивого учинека — Коля.

0,0(0 оценок)
Ответ:
shubiiin
shubiiin
17.03.2023 10:06

1)

var

  a: 100..999;

  a1, a2, a3: 0..9;   //а1 - сотни, а2 - десятки, а3 - единицы

 

begin

  writeln('введите натуральное трехзначное число');

  readln(a);

  a1: = a div 100;

  a2: = (a mod 100) div 10;

  a3: = a mod 10;

  writeln('полученное число:   ', a1, a3, a2);

end.

2)

var

  a: 100..999;

  a1, a2, a3: 0..9;

 

begin

   

  writeln('введите натуральное трехзначное число');

  readln(a);

  a1: = a div 100;

  a2: = (a mod 100) div 10;

  a3: = a mod 10;

  writeln('полученное число:   ', a2, a1, a3);

end.

3)

var

  a: 100..999;

  a1, a2, a3: 0..9;

 

begin 

  writeln('введите натуральное трехзначное число');

  readln(a);

  a1: = a div 100;

  a2: = (a mod 100) div 10;

  a3: = a mod 10;

  writeln('полученное число:   ', a3, a1, a2, a3);

end.

4)

var

  a: 1000..9999;

  a1, a2, a3, a4: 0..9;

 

begin

  writeln('введите натуральное четырехзначное число');

  readln(a);

  a1: = a div 1000;   //тысячи

  a2: = (a mod 1000) div 100;   //сотни

  a3: = (a mod 100) div 10;   //десятки

  a4: = a mod 10;   //единицы

  writeln('полученное число:   ', a4, a3, a2, a1);

end.

все остальное делается наподобие этого: просто в writeln меняешь местами цифры и все.

   

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота