В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
влад1922
влад1922
24.02.2023 04:56 •  Информатика

Составить алгоритм и написать программу для вычисления факториала числа. факториал числа обозначается n! , произносится эн факториа́л) — произведение всех натуральных чисел от 1 до n включительно: n ! = 1 ⋅ 2 ⋅ . 0! =1. пример: 4! = 1*2*3*4 = 24. выполнить двумя цикл с предусловием и с фиксированым числом повторений). все переменные целочисленные.

Показать ответ
Ответ:
ruslansuxenco3
ruslansuxenco3
03.08.2020 08:53
Var n,f,i:integer;
begin
write('n = ');
readln(n);
f:=1;
for i:=2 to n do f:=f*i;
writeln(n,'! = ',f);
end.

Пример:
n = 6
6! = 720
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота