Составь программу в тетради самостоятельно:Составить программу, в которой необходимо найти произведение двух чисел a*b Числа при запуске программы должны вводиться с клавиатуры
Во-первых, не whill, а while. Во-вторых, цикл с предусловием(while) выполняется только тогда, когда его условие возвращает ложь. Если условие возвращает правду, цикл завершается. Бывает так, что при попытке первой итерации цикла условие уже возвращает правду. В этом случае цикл не будет выполнен ни разу. Цикл с предусловием(repeat), наоборот, выполняется, пока условие возвращает правду и завершается ложью. Стоит заметить, что если цикл с предусловием проверяет своё условие перед итерацией, цикл с постусловием делает это после, а это значит, что последний выполнится хотя бы один раз.
Во-вторых, цикл с предусловием(while) выполняется только тогда, когда его условие возвращает ложь. Если условие возвращает правду, цикл завершается. Бывает так, что при попытке первой итерации цикла условие уже возвращает правду. В этом случае цикл не будет выполнен ни разу.
Цикл с предусловием(repeat), наоборот, выполняется, пока условие возвращает правду и завершается ложью. Стоит заметить, что если цикл с предусловием проверяет своё условие перед итерацией, цикл с постусловием делает это после, а это значит, что последний выполнится хотя бы один раз.
1)
#include <iostream>
using namespace std;
int main ()
{
int k = 0;
int n, m, a[100][100];
cin >> n >> m;
for (int i = 0; i < n; i++){
for (int j = 0; j < m; j++){
cin >> a[i][j];
}
}
for (int i = 0; i < n; i++){
for (int j = 0; j < m; j++){
if(a[i][j]==a[j][i]){
k++;
}
}
}
cout<<"Количество элементов a[i][j] = a[j][i], " << k << endl;
}
2)
#include <iostream>
using namespace std;
int main ()
{
int a[100], n, m,s = 0;
cout << "Введите количество элементов массива" << endl;
cin >> n;
cout << "Введите заданное число" << endl;
cin >> m;
for(int i = 0; i<n;i++){
cout << "Введите " << i+1 << " элемент массива" << endl;
cin >> a[i];
}
for(int i = 0; i<n;i++){
if(a[i] > m){
s+=a[i];
}
}
cout << "Сумма элементов, больших заданного числа "<< s << endl;
}