В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
sport22
sport22
17.02.2022 02:36 •  Информатика

Снаписанием программы в pascal. напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 5. программа получает на вход количество чисел в последовательности, а затем сами числа. в последовательности всегда имеется число, кратное 5. количество чисел не превышает 100. введённые числа не превышают 300. программа должна вывести одно число – сумму чисел, кратных 5.

Показать ответ
Ответ:
1greg
1greg
08.10.2020 16:51
Var
  n, sum, i, a: integer;
begin
  read(n);
  sum = 0;
  for i := 1 to n do
  begin
    read(a);
    if (a mod 5 = 0) then
      sum := sum + a;
  end;
  write(sum);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота