В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Никита20220
Никита20220
15.02.2022 21:17 •  Информатика

Сложное по информатике: нужно написать программу на паскале, не используя if, then, else, с таким результатом: введите число если число четное, то вывести 10; если нечетное, то вывести -10

Показать ответ
Ответ:
gaifuling4owmrcy
gaifuling4owmrcy
03.10.2020 20:44
Var a:integer;
begin
write('a = ');
readln(a);
writeln(-20*(abs(a) mod 2)+10);
end.

Пример:
a = 28
10
0,0(0 оценок)
Ответ:
машуля5552
машуля5552
03.10.2020 20:44
Var
n: integer;
res: boolean;
begin
readln(n);
res:=odd(n);
case res of
true: writeln('-10');
false: writeln('10');
end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота